error with PUT users

Any issue about Cyclos 4 scripting and Webservices

Moderators: rmvanarkel, hugo, alexandre

Post Reply
guigeek
Posts: 7
Joined: Fri May 08, 2020 11:26 am

error with PUT users

Post by guigeek »

Hi, i want to use API to change users with this :
Saves the user / operator profile felds. Only the basic fields (full name, login name, e-mail) and custom fields can be saved with this operation. Addresses, phones and images must be managed either via the full profile (GET /users/{user}/data-for-edit-profile / PUT /users/{user}/profile) or through their own paths.

But i have the following answer from the server :
{
"code": "staleEntity"
}

Do you know what it means ? I don't know and i don't know how to resolve this ?
Thanks !
Regards,
guigeek
Posts: 7
Joined: Fri May 08, 2020 11:26 am

Re: error with PUT users

Post by guigeek »

Nobody ? :cry:
guigeek
Posts: 7
Joined: Fri May 08, 2020 11:26 am

Re: error with PUT users

Post by guigeek »

Help ?
jakob.schumann
Posts: 24
Joined: Thu Apr 23, 2020 5:37 pm

Re: error with PUT users

Post by jakob.schumann »

In viewtopic.php?t=2376 it says for "staleEntity":
"MOBILE.GENERAL.error.staleEntity": "The data you are saving has been modified by another user or process. Please, reload the page and try again.",
Maybe this can give you a hint on what is going wrong. Like other requests updating the user before your PUT request does. Or maybe the version field is required and must be the same as the current user version or must be incremented in the PUT data.

Best regards,
JS
Post Reply