Assign Tokens API (tokenService.assign) does not work

Functionality discussions and feature requests

Moderators: hugo, alexandre, rmvanarkel

Post Reply
trustpay
Posts: 69
Joined: Mon Aug 03, 2015 10:19 am

Assign Tokens API (tokenService.assign) does not work

Post by trustpay »

Dear,

When we run Assign Token API (tokenService.assign), it always show error as attached picture
Please help me to solve this

Many thanks
Attachments
Assign token error.png
Assign token error.png (26.84 KiB) Viewed 893 times

alexandre
Posts: 871
Joined: Wed Sep 06, 2006 9:06 am

Re: Assign Tokens API (tokenService.assign) does not work

Post by alexandre »

Hi,

Verify if the user that you are using to assign has permission to do it, and also check if the user that will receive the token has the token type enabled at his permissions.

regards
Alexandre Caurrinhos
Cyclos development team.

trustpay
Posts: 69
Joined: Mon Aug 03, 2015 10:19 am

Re: Assign Tokens API (tokenService.assign) does not work

Post by trustpay »

Hi,

I've assigned permission for Admin and Member as attached picture already, but it's still error
Do I need to do anything more? or assign any permission more?

Thanks for your help
Attachments
admin permission.png
admin permission.png (17.99 KiB) Viewed 866 times
member permission.png
member permission.png (15.2 KiB) Viewed 866 times

alexandre
Posts: 871
Joined: Wed Sep 06, 2006 9:06 am

Re: Assign Tokens API (tokenService.assign) does not work

Post by alexandre »

Hi,

Sorry we found a bug on this method when it is called via webservice.
We made a fix on the version 4.8.4 that was published today.

Regards
Alexandre Caurrinhos
Cyclos development team.

Post Reply