ERROR TypeError

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
atitokor
Posts: 46
Joined: Tue Jan 01, 2019 8:33 pm

ERROR TypeError

Post by atitokor » Tue May 07, 2019 11:21 pm

I've set up 4ui but it's returning an error and treating it as a failure. Here's the error message in developer console:

Code: Select all

ERROR TypeError: You provided 'undefined' where a stream was expected. You can provide an Observable, Promise, Array, or Iterable.
    at c (main.0d58fd45345b5ffca6d0.js:1)
    at a (main.0d58fd45345b5ffca6d0.js:1)
    at t.error (main.0d58fd45345b5ffca6d0.js:1)
    at t._error (main.0d58fd45345b5ffca6d0.js:1)
    at t.error (main.0d58fd45345b5ffca6d0.js:1)
    at t._error (main.0d58fd45345b5ffca6d0.js:1)
    at t.error (main.0d58fd45345b5ffca6d0.js:1)
    at t._error (main.0d58fd45345b5ffca6d0.js:1)
    at t.error (main.0d58fd45345b5ffca6d0.js:1)
    at t._error (main.0d58fd45345b5ffca6d0.js:1)
Tf @ main.0d58fd45345b5ffca6d0.js:1
And bellow is my full httpd log which seems to show that Apache is working fine and connecting with the API. I'm using CORS.

Code: Select all

[Tue May 07 23:44:27.964873 2019] [mpm_event:notice] [pid 1:tid 140054123393088] AH00489: Apache/2.4.39 (Unix) configured -- resuming normal operations
[Tue May 07 23:44:27.965203 2019] [core:notice] [pid 1:tid 140054123393088] AH00094: Command line: '/usr/local/apache2/bin/httpd -D FOREGROUND'
76.x.x.6 - - [07/May/2019:23:46:07 +0000] "GET / HTTP/1.1" 200 2187
76.x.x.6 - - [07/May/2019:23:46:08 +0000] "GET /images/spinner.svg HTTP/1.1" 200 942
76.x.x.6 - - [07/May/2019:23:46:08 +0000] "GET /runtime.71a434d9d30df9872f9a.js HTTP/1.1" 200 2383
76.x.x.6 - - [07/May/2019:23:46:08 +0000] "GET /polyfills.ab5fbb32515c8387d011.js HTTP/1.1" 200 63214
76.x.x.6 - - [07/May/2019:23:46:08 +0000] "GET /styles.5c78cb94fef0c4dd0a9b.css HTTP/1.1" 200 186908
76.x.x.6 - - [07/May/2019:23:46:09 +0000] "GET /close.d9d2d0b1308cb694aa81.png HTTP/1.1" 200 280
76.x.x.6 - - [07/May/2019:23:46:09 +0000] "GET /prev.84b76dee6b27b795e89e.png HTTP/1.1" 200 1360
76.x.x.6 - - [07/May/2019:23:46:09 +0000] "GET /loading.2299ad0b3f63413f026d.gif HTTP/1.1" 200 8476
76.x.x.6 - - [07/May/2019:23:46:09 +0000] "GET /next.31f15875975aab690854.png HTTP/1.1" 200 1350
76.x.x.6 - - [07/May/2019:23:46:08 +0000] "GET /main.0d58fd45345b5ffca6d0.js HTTP/1.1" 200 2192626
76.x.x.6 - - [07/May/2019:23:46:13 +0000] "GET /api/ui/data-for-ui?kind=custom HTTP/1.1" 200 2187
76.x.x.6 - - [07/May/2019:23:46:13 +0000] "GET /images/logo.png HTTP/1.1" 200 5430
Thanks in advance Alexandre, Luis, Hugo, and all Admin Team members for making time to look into this as we know your schedules are heavily loaded with getting out 4.12
Art

Post Reply