Pay to user bugs on web navigator after typing account number

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
Abisbis
Posts: 15
Joined: Sat Nov 30, 2019 6:34 pm

Pay to user bugs on web navigator after typing account number

Post by Abisbis »

Hello,

I have a problem with my configuration.

"Pay to user" does not work on web navigator. It works on mobile app, and "request payment" works on both.

When I enter the account number, it is identified but I have an error message showing up.

Image

Image

I do not know where to find the logs corresponding to this error. I went to catalina.out logs, but I can't identify this bug in this file. Any idea ?

The bug occurs under Chrome and Edge, so I think it's not linked to navigator.

I have no indication beside "validation errors occured"

Thanks
Abisbis
Posts: 15
Joined: Sat Nov 30, 2019 6:34 pm

Re: Pay to user bugs on web navigator after typing account number

Post by Abisbis »

These are some things I have in localhost_acces_log after having this error :

127.0.0.1 - - [18/Dec/2019:12:15:25 +0100] "POST /web-rpc/transactionService HTTP/1.1" 404 165

127.0.0.1 - - [18/Dec/2019:12:15:29 +0100] "POST /web-rpc/transactionService HTTP/1.1" 200 1674

127.0.0.1 - - [18/Dec/2019:12:15:29 +0100] "POST /web-rpc/transactionService HTTP/1.1" 400 171


I think the real problem is 400 171 but what does "171" means ?
Last edited by Abisbis on Thu Dec 26, 2019 8:49 pm, edited 1 time in total.
alexandre
Posts: 913
Joined: Wed Sep 06, 2006 9:06 am

Re: Pay to user bugs on web navigator after typing account number

Post by alexandre »

Hi,

I cannot reproduce the problem.
Can you test it with the latest cyclos version (4.12.4).
If the problem still happen with the latest version, send a db dump to info@cyclos.org.

Regards
Alexandre Caurrinhos
Cyclos development team.
Abisbis
Posts: 15
Joined: Sat Nov 30, 2019 6:34 pm

Re: Pay to user bugs on web navigator after typing account number

Post by Abisbis »

I will try with 4.12.4

I have other messages that I try to investigate :

WARNING: An illegal reflective access operation has occurred WARNING: Illegal reflective access by org.apache.commons.lang3.reflect.MethodUtils (file:... /commons-lang3-3.8.1.jar) to method sun.util.calendar.ZoneInfo.clone() WARNING: Please consider reporting this to the maintainers of org.apache.commons.lang3.reflect.MethodUtils
Last edited by Abisbis on Thu Dec 26, 2019 8:48 pm, edited 1 time in total.
alexandre
Posts: 913
Joined: Wed Sep 06, 2006 9:06 am

Re: Pay to user bugs on web navigator after typing account number

Post by alexandre »

Hi,
The db dump that you sent are corrupted, we cannot restore.
Follow the steps from the documentation to make a new backup and sent it again.
https://documentation.cyclos.org/4.12/c ... nance.html

regards
Alexandre Caurrinhos
Cyclos development team.
Abisbis
Posts: 15
Joined: Sat Nov 30, 2019 6:34 pm

Re: Pay to user bugs on web navigator after typing account number

Post by Abisbis »

I've sent you the dropbox link, can you confirm that you can open it this time ?

Thanks
alexandre
Posts: 913
Joined: Wed Sep 06, 2006 9:06 am

Re: Pay to user bugs on web navigator after typing account number

Post by alexandre »

Hi,

I can read the dump now.
The problem is that you have disabled all identification methods on payments and leave only account number, but you set the account number as not visible for the users so it generates this error.
To work you just need to set the account number visible on the user product at "Profile fields of other users".
See the attached image.
Seleção_170.png
Seleção_170.png (32.76 KiB) Viewed 2287 times

regards
Alexandre Caurrinhos
Cyclos development team.
Abisbis
Posts: 15
Joined: Sat Nov 30, 2019 6:34 pm

Re: Pay to user bugs on web navigator after typing account number

Post by Abisbis »

Yep, that works fine now!

The only problem left is the illegal reflective stuff in the logs, but since I don't see functional problems, that shouldn't be a problem!

Thanks
admin
Site Admin
Posts: 1423
Joined: Mon Jan 24, 2005 10:31 am

Re: Pay to user bugs on web navigator after typing account number

Post by admin »

Regarding the CoyoteAdapter.asyncDispatch Exception is something that can be safely ignored. Sometimes Tomcat logs it for push notification requests.
Regarding the other error, WARNING: Illegal reflective access, it is probably only generated on Java versions greater than 8.
We use Java 8 in all our environments, and never saw it. Something you might try is to replace the commons-lang 3 jar in WEB-INF/lib with the latest version (3.9) (just don't forget to remove the previous jar). But it won't likely do any harm in runtime.
Post Reply