problem calling a library by cron job

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
jar
Posts: 97
Joined: Mon Apr 20, 2015 8:55 am

problem calling a library by cron job

Post by jar » Tue Nov 20, 2018 3:26 pm

Hi,

We have detected that from version 4.8 to 4.9 (and this issue still exists up to Cyclos 4.11.1) one of our scripts has stopped working. It is simply not detecting the library being called by the cron job.
I think we have everything well created, if we execute the script directly in cyclos in the option "Execute script" it works and detects our library.

We wanted to know if there were any changes to the functionality of the cron job?

Best regards,

JAR
Thanks for your kind attention.
Best regards,

JAR

alexandre
Posts: 837
Joined: Wed Sep 06, 2006 9:06 am

Re: problem calling a library by cron job

Post by alexandre » Tue Nov 20, 2018 3:58 pm

Hi,

This are the changes from 4.8 to 4.9:
https://documentation.cyclos.org/4.9/sc ... anges.html

What is the error that you have, send the log.

regards
Alexandre Caurrinhos
Cyclos development team.

jar
Posts: 97
Joined: Mon Apr 20, 2015 8:55 am

Re: problem calling a library by cron job

Post by jar » Wed Nov 21, 2018 7:15 am

We don't use any of the packages referred in the link you gave us in the last message.
Cyclos doesn't show an error message. It simply ignores the scheduled task.
Thanks for your kind attention.
Best regards,

JAR

jar
Posts: 97
Joined: Mon Apr 20, 2015 8:55 am

Re: problem calling a library by cron job

Post by jar » Wed Nov 28, 2018 12:12 pm

Good afternoon,

When the scheduled task runs, it ignores our library that is associated with the script that performs the task. If we run through the "Run Script" menu it runs smoothly.
Does not return any exceptions.

What are we doing wrong to be ignoring the library?

Thank you.
Thanks for your kind attention.
Best regards,

JAR

alexandre
Posts: 837
Joined: Wed Sep 06, 2006 9:06 am

Re: problem calling a library by cron job

Post by alexandre » Wed Nov 28, 2018 1:30 pm

Hi,

We cannot reproduce this problem.
If you want send a db dump with the problem description and steps to reproduce to info@cyclos.org and I will have a look.

regards
Alexandre Caurrinhos
Cyclos development team.

Post Reply