Class$S2403 error

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
jar
Posts: 97
Joined: Mon Apr 20, 2015 8:55 am

Class$S2403 error

Post by jar » Tue May 29, 2018 3:19 pm

Hi,

We received a message from a broker telling us that after creating a new access client to an user, they received this error message.

Ocorreu um erro inesperado durante o processamento da sua solicitação: (this means comething like this in English: it occured an unexpected error while processing your request)
undefined
Class$S2403

What is the meaning of this error?
Thanks
Thanks for your kind attention.
Best regards,

JAR

alexandre
Posts: 837
Joined: Wed Sep 06, 2006 9:06 am

Re: Class$S2403 error

Post by alexandre » Tue May 29, 2018 5:42 pm

Hi,

What is your cyclos version?
Also have a look at the log files and check if you can find the error trace.

Regards
Alexandre Caurrinhos
Cyclos development team.

jar
Posts: 97
Joined: Mon Apr 20, 2015 8:55 am

Re: Class$S2403 error

Post by jar » Tue May 29, 2018 7:07 pm

Cyclos 4.8.5
Thanks for your kind attention.
Best regards,

JAR

nichemley
Posts: 2
Joined: Wed Nov 07, 2018 1:52 pm

Re: Class$S2403 error

Post by nichemley » Wed Jan 09, 2019 10:54 am

Hello all,

Was there a resolution to this problem, please? We are seeing the same on Cyclos 4.10.

Error as follows:
There was an unexpected error while processing your request:
undefined
Class$S110

Any pointers appreciated since there is nothing in the logs.

Thanks!

Cheerio,
Nic

simonjwoolf
Posts: 111
Joined: Mon May 28, 2012 8:49 am

Re: Class$S2403 error

Post by simonjwoolf » Wed Jan 09, 2019 11:03 am

These errors seem to occur randonly, for us only after we upgraded first to 4.10 and then to 4.11.2 which does not solve the issue.

The errors seem to be related to instability of the Tomcat application, which sometimes completely freezes or restarts itself. The only solution is to manuallly restart the tomcat app.

No errors appear to be logged to catalina.out in these scenarios, so it is close to impossible to troubleshoot.

Here is a sample screenshot of one of the errors experieneced on the login screen, when the app is in this unstable state.
Screenshot from 2019-01-09 13-47-30.png
Screenshot from 2019-01-09 13-47-30.png (122.01 KiB) Viewed 555 times
---
Simon Woolf
Cyclos Consultant

admin
Site Admin
Posts: 1413
Joined: Mon Jan 24, 2005 10:31 am

Re: Class$S2403 error

Post by admin » Wed Jan 09, 2019 12:52 pm

It looks to be an environment issue. Problems like this are often related to memory settings.
Here is some documentation on that: https://documentation.cyclos.org/4.11/c ... tml#d0e445
You could increase the -Xmx512m to 1 Gb. The -XX:MaxPermSize= settings is not needed with the latest tomcat version.
It would be good make sure you have the latest tomcat version.

Hope this helps

Post Reply