Unexpected error message

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
Joan
Posts: 197
Joined: Thu Jan 09, 2014 1:18 pm
Location: Barcelona
Contact:

Unexpected error message

Post by Joan »

error.jpg
error.jpg (204.7 KiB) Viewed 1597 times
Hi,
When a payment is made, the system send an automatic e-mail to the payer and to the beneficiary.
When they click on the link and login on our communitie (http://www.ecotracte.org) appears next message:
There was an unexpected error while processing your request:
For input string: "7762070814250490431""

Many thanks in advance!

alexandre
Posts: 907
Joined: Wed Sep 06, 2006 9:06 am

Re: Unexpected error message

Post by alexandre »

Hi,

I cannot reproduce the problem.
Can you test if it still have problem and send more informations about it.

Regards
Alexandre Caurrinhos
Cyclos development team.

Joan
Posts: 197
Joined: Thu Jan 09, 2014 1:18 pm
Location: Barcelona
Contact:

Re: Unexpected error message

Post by Joan »

Hi Alexandre,

The problem remains. For automatic community notifications we use Gmail.
About it, it's happen only on our community. We test this problem on an old Cyclos communitie and works all OK.
We see that the link sended is not correct, it have too characters (on Gmail). Deleting the last three characters, the link works ok.
The links runs ok when is received on Yahoo e-mail but is wrong on Gmail.
Please, tell me some e-mail (better Gmail) where to receive the message with the link so you can try it.
You can send it to ecotracte@gmail.com.
Then I create an user test with your e-mail and then I make a test payment to you.
Then you receive a payment notification with the incorrect link.
After I will send a message to your e-mail with your credentials for login on ecotracte.org and you can see the error message.
Once the problem is solved, I delete this user test.
Agree?
Or do it yourself?

Kind regards,

alexandre
Posts: 907
Joined: Wed Sep 06, 2006 9:06 am

Re: Unexpected error message

Post by alexandre »

Hi,

can you check if you have a translation key personalized at your instance.
You can check it on the menu content - > application translation and choose to show all customized keys.

It seems that the key was changed but as it is personalized at your instance it will not work as expected.

regards
Alexandre Caurrinhos
Cyclos development team.

alexandre
Posts: 907
Joined: Wed Sep 06, 2006 9:06 am

Re: Unexpected error message

Post by alexandre »

I Found the problem.
It Was a problem with your customized translation key "GENERAL.EMAILS.notification.body"
It was missing some " at the html.
I fixed it for you.

regards
Alexandre Caurrinhos
Cyclos development team.

Joan
Posts: 197
Joined: Thu Jan 09, 2014 1:18 pm
Location: Barcelona
Contact:

Re: Unexpected error message

Post by Joan »

Problem solved!
Muito agradecidos, Alexandre.
Saudações de Barcelona.

Post Reply