Last performed payment filter is not behaving as expected

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Last performed payment filter is not behaving as expected

Post by rhornig »

In Banking / User balances / Advanced (Search)/ Last performed payment and last received payment date filter is not working as expected.

Based on the name of the field *Last* performed payment I would expect that this would filter out all users whose LAST payment transaction was in that date range. Instead it filters out those users, who had any payment transaction in that date range even if the had payment activity AFTER the end date. I.e. this filter is more behaving like: Payment activity date

I would love to filter out inactive users that have not made a single purchase in the last half a year. The last payment date filter would be ideal for this.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Last performed payment filter is not behaving as expecte

Post by rhornig »

Is this probably fixed in 4.8beta? I can't see it in the change log, but I might have missed it.
alexandre
Posts: 938
Joined: Wed Sep 06, 2006 9:06 am

Re: Last performed payment filter is not behaving as expecte

Post by alexandre »

Hi,

Sorry for the late response.
This will be fixed on version 4.8.

regards
Alexandre Caurrinhos
Cyclos development team.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Last performed payment filter is not behaving as expecte

Post by rhornig »

Thanks for taking care of this. It will be rather useful for me.

Just out of curiosity. Is there a more formal bugtracker for cyclos, or community bugreporting is handled via this forum only?
Post Reply