System Account to User Account Transaction Missing

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
Shiyghan
Posts: 39
Joined: Thu Jun 16, 2016 9:16 am
Location: London
Contact:

System Account to User Account Transaction Missing

Post by Shiyghan »

When a transfer is performed from a System Debit Account to a User Account, the funds are credited to the User Account, but it does not appear in the statement of accounts.

In the image below, 92pts and £31.77 is transferred from a GBP and pts System Debit Accounts to the School User's account. The account summary is as shown below
Screen Shot 2016-12-07 at 9.50.00 PM.png
Screen Shot 2016-12-07 at 9.50.00 PM.png (43.29 KiB) Viewed 2570 times
Although the correct amount is credited to the account, the transaction list / statements do not include a reference 92pts or £31.77. We have also implemented the PayPal scripts and we get a similar behavior. The PayPal payment is registered and the account credited, but the credit does not appear in the User Account.
Screen Shot 2016-12-07 at 9.51.14 PM.png
Screen Shot 2016-12-07 at 9.51.14 PM.png (73.71 KiB) Viewed 2570 times
Screen Shot 2016-12-07 at 9.51.29 PM.png
Screen Shot 2016-12-07 at 9.51.29 PM.png (84.69 KiB) Viewed 2570 times
Skype senavti
Shiyghan
Posts: 39
Joined: Thu Jun 16, 2016 9:16 am
Location: London
Contact:

Re: System Account to User Account Transaction Missing

Post by Shiyghan »

Below is the account summary for a user as seen by an administrator, as well as the summary when the user sign in.

It appears that all transactions from a System Account to the User's account are missing from the list of transactions displayed to the user.

User Account Summary as Administrator
Screen Shot 2016-12-07 at 11.19.36 PM.png
Screen Shot 2016-12-07 at 11.19.36 PM.png (122.91 KiB) Viewed 2568 times
User Account Summary as User
Screen Shot 2016-12-07 at 11.20.18 PM.png
Screen Shot 2016-12-07 at 11.20.18 PM.png (116.71 KiB) Viewed 2568 times
Skype senavti
alexandre
Posts: 913
Joined: Wed Sep 06, 2006 9:06 am

Re: System Account to User Account Transaction Missing

Post by alexandre »

It's a bug, and will be fixed on version 4.7.1.
It happens when the user does not have his own group on the accessible groups permission.

Thanks for report.
Regards
Alexandre Caurrinhos
Cyclos development team.
Post Reply