Payment Request Submit button is always gray

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Payment Request Submit button is always gray

Post by rhornig »

My users are reporting that since some time on communities.cyclos.org/tm the Banking / Receive Payment function is no longer working. The grayed out Submit button is never activated. Does anyone have a solution?
alexandre
Posts: 938
Joined: Wed Sep 06, 2006 9:06 am

Re: Payment Request Submit button is always gray

Post by alexandre »

Hi,

The button submit will be available when a valid user and transter type is selected.

Regards
Alexandre Caurrinhos
Cyclos development team.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Payment Request Submit button is always gray

Post by rhornig »

Thanks Alexandre,

The button was previously working fine and I made no changes to the configuration at all. Users started to report this in September. Additionally the same function works fine inthe Mobile apps.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Payment Request Submit button is always gray

Post by rhornig »

Any hint about what could have changed? The same transaction can be carried out on the Mobile app, but not on the web interface. It means that it cannot be a configuration issue (except if the transaction is specifically disable on the web channel). There was no configuration change from my part, so the only thing I can think of:

- a bug introduced with an update
- a new feature, configuration value introduced by an update that should be manually configured to enable the payment again (i.e. some additional check was added somewhere). I've checked the release changelogs but could not figure out anything.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Payment Request Submit button is always gray

Post by rhornig »

A bit further investigation shows that his is clearly a client side rendering BUG:

Once I've entered the username and amount on the Receive Payment page, the Submit button still remains disabled.

Opening the HTML inspector and checking the Button code shows:

<button type="button" class="actionButton actionButton-disabled" disabled=""><div class="actionButtonText">Submit</div></button>

Simply removing the "disabled" tag allows you to successfully carry out the transaction so this is clearly just a bug which prevents the user to click the button.
alexandre
Posts: 938
Joined: Wed Sep 06, 2006 9:06 am

Re: Payment Request Submit button is always gray

Post by alexandre »

Hi,
We made an update yesterday on Cyclos Communities.
It has several enhancements and a fix on the receive payment form.

Can you have a look and check if it is ok now?

regards
Alexandre Caurrinhos
Cyclos development team.
rhornig
Posts: 37
Joined: Thu Jul 31, 2014 9:20 am

Re: Payment Request Submit button is always gray

Post by rhornig »

Yes. It's now working correctly. Thanks a lot for you great work.
Post Reply