Bug international phone numbers SMS parameter "to"

Bug and problem reporting on Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
cycloshost
Posts: 578
Joined: Mon Jan 30, 2012 8:12 am
Contact:

Bug international phone numbers SMS parameter "to"

Post by cycloshost »

Hi,

when setting in System -> Configuration -> Localization a country, only the SMS to numbers of this country work, international numbers doesn't work.

To reproduce it in communities:
Use the network id 7762070814178144319.
Localization country of the network is Germany.
User id 7762070814179569215 has a german mobile +49176XXX in profile. The parameter "to" of the Gateway URL is "+49176XXX" when triggering an SMS action, for example acinfo.
User id 7762070814179613759 has a spanish mobile +34678YYY. Here is not working, as the parameter "to" of the Gateway URL is "+4934678YYY".

The call is working as expected, so the url sms?from=+34678XXX&message=acinfo is working fine. Problem is only in outbound, and the message "Unregistered phone. Please, register first." is always triggered.

That means, for international numbers, Cyclos seems to be adding the prefix of the country configured in localization settings. It took us a lot of time to debug this, i hope you can reproduce it. There is a requestbin with some testing that you can consult configured in the Gateway SMS URL configuration of this network.

Thanks!
cycloshost.com
Cyclos administration and hosting
Post Reply