Japanese

Any communication concerning the translations of the Cyclos3 version

Moderators: hugo, alexandre, rmvanarkel

admin
Site Admin
Posts: 1413
Joined: Mon Jan 24, 2005 10:31 am

Japanese

Post by admin » Thu Sep 21, 2006 3:48 pm

Any communication about the Japanese translation.

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Japanese character problem

Post by mikami » Mon Aug 04, 2008 12:43 pm

Hi,

I'm running Cyclos 3.0.8 in standalone mode, using MySQL.
Both MySQL and Cyclos itself are set to UTF-8.

To prevent Japanese characters (UTF-8) from getting garbled, I had to define charset at the head of some jsp files.
(Or, is this a Jetty-specific problem?)

In all the help files and static files, I added:

Code: Select all

<%@ page language="java" contentType="text/html; charset=utf-8" pageEncoding="utf-8" %>
Also for the mobile service, I added the same code in the 'web/mobile/index.jsp' file, and removed the code "escapeHTML" from the following two files.
  • web/pages/mobile/confirmPayment.jsp
    web/pages/mobile/error.jsp
(I'm not sure this is peculiar to Japanese mobile phones, or a general UTF-8 problem in the mobile service.)

By these modifications, Cyclos seems to work fine in Japanese.
Is there any better solution?

Regards,
Mikami

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Tue Aug 12, 2008 11:55 am

Hi Mikami,

It is better not to remove the "escapeHTML" tag because that might cause the layout to break.
It is hard to see what is going on. Could you send the database to ccsoftware@strohalm.nl ? Then we can have a better look.

Regards, Hugo

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Tue Aug 12, 2008 1:37 pm

Hi Hugo,

Thank you for your response.
I have just sent the sql file to you.

I tried with escapeHTML tag on several models of Japanese mobile phones,
but those two pages didn't show Japanese text (nor any text).
Via PC's web browser, I could see the text without problems, though.

Please let me know if you need more information.


Regards,
Mikami
Last edited by mikami on Tue Aug 12, 2008 11:06 pm, edited 1 time in total.

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Tue Aug 12, 2008 2:20 pm

We got your mail. We will have a look and come back to you soon.

Hugo

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Fri Aug 15, 2008 11:21 am

Hi Mikami,

We loaded your database and application properties. It shows well. Even without defining utf-8 in the static files and helps. I don't know why it works for us.
Anyway I don't think that there will be an simplier way to do it than you did now. I suggest you do the changes from the customization function. This way your changes will stay in the database and it won't cause any issues if you need to upgrade to a newer version.

Regards, Hugo

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Sat Aug 16, 2008 1:28 am

Hi Hugo,

Thank you for your advice.

I tested with mobile phones of another carrier (KDDI), and they showed Japanese well even with the "escapeHTML" tag.
After all, the problem seems to be due to the particular browser of NTT Docomo, the Japanese largest mobile phone carrier.

Apart from this, I have not yet identified the cause of Japanese static and help files getting garbled.
On your advice, I will define UTF-8 from the customization function after I finish the translation on the text editor.

Regards,
Mikami

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Wed Aug 20, 2008 9:50 am

Hi Mikami,

Ok, For us it is hard to see if static files are garbeld or not with the Japanese characters. If your work around works fine I suggest you work from that. If you really have a problem we might have to compare the screanshots.

Just let me know if you need more help.

Regards, Hugo

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Thu Aug 28, 2008 4:33 pm

Hi Hugo,

I have just finished all the translation work and sent you the properties, help and static files by e-mail.
Those files are without UTF-8 definition.
It would be very helpful if you would check whether they show Japanese well.
(I also attached my screenshots so that you can check it.)
If so, I might have some sort of character encoding problems outside Cyclos.

And now, I have some questions.
  • Could you upload my translation files to sourceforge or the project site to make them available to other users?
  • Does the translation for Cyclos 3.0.8 have some compatibility with Cyclos 3.5 or later?
Regards,
Mikami

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Mon Sep 01, 2008 4:32 pm

Hi mikami,

I received the files. If you can send the setup properties we will include it in cyclos3.0.9.

Now the bad news.

Cyclos 3.0 does not have compatibility with Cyclos 3.5. This was a difficult desicion. The motive is explained at the project site (copied here below)

Regards, Hugo

In Cyclos 3.5 all help files have been reassembled by main subjects (e.g. payments, references, advertisements, account management, etc). There are a total of 32 help files with a fixed format. The working will be much the same as before. Users can click on the help icons on the funcion windows that will open the help file in a pop-up window and jump to the paragraph of the specific function.
The manuals will be constructed automaticaly from the help files. This way it will be considerably easier for the translators and also easier to maintain the translation. With every release we will publish a 'difference' file that shows (in different colors) all new and modified texts.

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Tue Sep 02, 2008 5:21 am

Hi Hugo,

I've sent you the setup properties.
Having translated all the help files, I agree that reassembling them is good idea.

Thank you again for your kind assistance.
I'm looking forward to Cyclos 3.0.9 and 3.5.

Regards,
Mikami

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Tue Sep 02, 2008 2:53 pm

We uploaded the version 3.0.9 with the Japanese translation files

First you have to create the new database (mysql) with the utf argument:
create database cyclos default charset utf8;

Then in Cyclos properties you have to set the locale to:
cyclos.embedded.locale = ja_JP

And change the database encoding to:
#hibernate.connection.url = jdbc:mysql://localhost/cyclos?useUnicode=true&characterEncoding=utf8

From version 3.5 Cyclos will support only UTF8 what will solve these kind of language problems.

Regards, Hugo

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Sun Mar 15, 2009 2:56 pm

Hi,

When Cyclos 3.0.9 is set to Japanese in the local settings,
upgrading it to version 3.5 causes a problem.
It seems to fail to configure the accessible channel setting for members,
and all the members (not admins) become unable to login.
(Going to Menu->Permission Groups->Modify member group->Access settings,
there appear no items in the 'Accessible channels' and 'Default channels' drop-down boxes.)
I could avoid this problem by setting language to English before upgrading.

This is because version 3.0.9 has Japanese and version 3.5 does not, isn't it?
Now I'm working on Japanese translation of version 3.5_RC1,
and the application properties file is almost finished.
Where can I find CyclosSetup.properties?
(not found in the Sourceforge packages)

Regards,
Mikami

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Mon Mar 16, 2009 9:52 am

Hi Mikami,

Good news that you are translation cyclos3.5
This is because version 3.0.9 has Japanese and version 3.5 does not, isn't it?
Yes exactly. Once the properties file is translated all options will show up.

The setup properties is not published in the current release. In the next release that will be published this week (RC1a) you will find the file in the directory
/cyclos_3.5_RC1/src/nl/strohalm/cyclos/setup/

mikami
Posts: 10
Joined: Mon Aug 04, 2008 9:27 am
Location: Japan

Post by mikami » Sun Nov 08, 2009 4:25 am

Hi,

I found a slight problem in Cyclos 3.5.4.
In "Translation - Notifications" setting, the item "PIN blocked by invalid trials" does not reflect the translations well.
The setting name is shown in Japanese (or in any other language), but Subject, Body and SMS Message remain in English.
They seem to certainly have the corresponding keys in the properties file, so I don't know why.

Regards,
Mikami

Post Reply