Advertisement count error

Bug and problem reporting

Moderators: rmvanarkel, hugo, alexandre

Post Reply
voiceinthewild
Posts: 40
Joined: Thu Nov 25, 2010 8:00 am
Location: Canada

Advertisement count error

Post by voiceinthewild »

After a name change to an advertisement category, it seems that it caused the count to show zero, when actually there are two ads there.

thanks
Ed
voiceinthewild
Posts: 40
Joined: Thu Nov 25, 2010 8:00 am
Location: Canada

Post by voiceinthewild »

I'm using v3.5.6.
admin
Site Admin
Posts: 1424
Joined: Mon Jan 24, 2005 10:31 am

Post by admin »

Rebuilding the indexing would help. There is an option to do this from the cyclos admin section in 3.6. But this is not available for 3.5
You can just delete them from the file system by stopping tomcat, and deleting the directory /web-inf/indexes/
and restart tomcat again.
voiceinthewild
Posts: 40
Joined: Thu Nov 25, 2010 8:00 am
Location: Canada

Post by voiceinthewild »

Appreciate the hint admin, but it doesn't seem to help. Not even coupled with reindexing the database (backup/restore).

thanks
Ed
voiceinthewild
Posts: 40
Joined: Thu Nov 25, 2010 8:00 am
Location: Canada

Post by voiceinthewild »

As well, it seems that if you manually expire an ad as an admin (as the member themselves also?), the count will also be off.

thanks
Ed
kurt.specht
Posts: 13
Joined: Thu Jan 20, 2011 9:03 am

Post by kurt.specht »

Hi there,

the re-indexing works (for me) for the ads already deleted, but ads deleted after the re-indexing experience the same issue. So one has to create a cron job to do this regularely.
Could you look into fixing this issue permanently in the 3.6 version please?

Many thanks,
Kurt
voiceinthewild
Posts: 40
Joined: Thu Nov 25, 2010 8:00 am
Location: Canada

Post by voiceinthewild »

kurt.specht wrote:
the re-indexing works (for me) for the ads already deleted, but ads deleted after the re-indexing experience the same issue. So one has to create a cron job to do this regularely.

Many thanks,
Kurt
Kurt -

I'm curious why and how re-indexing works for you other than what admin suggested. I'll probably try it again when needed. I'm assuming you're also using v3.5.6.

As it is now, it's tedious (to say the least) to keep the counts correct whenever categories and subcategories need to be edited/added/deleted.

What about other folks? This must be a common issue? Or did somebody tweak the code?

thanks
Ed
kurt.specht
Posts: 13
Joined: Thu Jan 20, 2011 9:03 am

Post by kurt.specht »

Ed,
the point I wanted to make was that it works as suggested when deleting the index folder and restarting Tomcat.
Cheers,
Kurt
rinke
Posts: 87
Joined: Thu Mar 31, 2005 4:54 pm

count ads in category

Post by rinke »

Nevertheless, this is of course not behavior as it should be. I've added it to the buglist, so it will probably be solved in the next version.
________________________
Rinke Hoekstra
cyclos project team,
STRO.
Post Reply