Registration agreements not working from external login

Bug and problem reporting

Moderators: hugo, alexandre, rmvanarkel

Post Reply
lmicetic
Posts: 10
Joined: Wed Apr 29, 2009 10:35 am

Registration agreements not working from external login

Post by lmicetic » Tue Feb 23, 2010 8:37 pm

When adding registration agreement to a group and checking 'Force accept' - agreement shows only to users which log in through standard login page.
Users logging in from external login page (ie frame) don't see agreement and they don't have to accept it in order to continue.

admin
Site Admin
Posts: 1413
Joined: Mon Jan 24, 2005 10:31 am

Post by admin » Wed Feb 24, 2010 11:19 am

There are various projects using external login with a regisration agreement. (and cyclos3.6).
Can you post (or send) the website url so that we can have a look?

lmicetic
Posts: 10
Joined: Wed Apr 29, 2009 10:35 am

Post by lmicetic » Fri Mar 05, 2010 4:33 pm

You can try it on initial empty cyclos instalation too. Upon creation of demo user and assigning him a registration agreement - logout and go to /do/login and everything should be all right (url shows: /do/acceptRegistrationAgreement).
If you try to login from /do/externalLogin (should be same thing, right?) it will skip registrationAgreementCheck and go straight to /do/member/home

hugo
Posts: 633
Joined: Sun Jun 18, 2006 1:40 pm

Post by hugo » Mon Mar 15, 2010 3:14 pm

Yes this is a bug. Thanks for reporting this.
It will be fixed in the next release.

localliz
Posts: 2
Joined: Fri Nov 03, 2017 10:00 am

Re: Registration agreements not working from external login

Post by localliz » Fri Apr 20, 2018 11:01 am

This is not working again! I need help.....we cannot reach out 300 user minimum b/c they are getting an error registering!

Post Reply