[Cyclos 3.7.3] Dependent List Fields: Filter not working

Bug and problem reporting

Moderators: hugo, alexandre, rmvanarkel

Post Reply
netswerk
Posts: 18
Joined: Mon Nov 26, 2012 12:45 pm

[Cyclos 3.7.3] Dependent List Fields: Filter not working

Post by netswerk » Thu May 30, 2013 3:33 pm

Hi there,

on editing dependent list fields (in my case member custom fields): if I choose the value for the first (main) field, the filter works fine for the second (dependent) field: only a subselection of the values is shown.
However, once I have saved values and try to edit again, if I only open the second field (without touching the first field at all), then ALL values are shown for the second field. If I change the value for the second field, I can save it, no matter what the value of the first field was.

I wouldn't mind so much that all the values are shown at first - however being able to save incorrect values unfortunately makes this feature unusable for me.

Cheers

Lydia

netswerk
Posts: 18
Joined: Mon Nov 26, 2012 12:45 pm

Re: [Cyclos 3.7.3] Dependent List Fields: Filter not working

Post by netswerk » Wed Jun 12, 2013 12:54 pm

Hi there,

has anyone been able to verify this?

Thanks

Lydia

admin
Site Admin
Posts: 1413
Joined: Mon Jan 24, 2005 10:31 am

Re: [Cyclos 3.7.3] Dependent List Fields: Filter not working

Post by admin » Wed Jun 12, 2013 1:53 pm

Hi, we will have a look at it.

alexandre
Posts: 837
Joined: Wed Sep 06, 2006 9:06 am

Re: [Cyclos 3.7.3] Dependent List Fields: Filter not working

Post by alexandre » Fri Jun 14, 2013 1:29 pm

HI,

We confirm this Bug, this will be fixed on the next version (3.7.4).

Thanks for reporting this.

Regards
Alexandre Caurrinhos
Cyclos development team.

Post Reply