[ Cyclos 3.6 ] Cyclos hangs with certain SMTP values

Bug and problem reporting

Moderators: rmvanarkel, hugo, alexandre

Post Reply
Posts: 54
Joined: Fri Feb 12, 2010 8:30 am

[ Cyclos 3.6 ] Cyclos hangs with certain SMTP values

Post by timreeves »

In Settings => Email I was using Port 465 and TLS Yes. These were correct settings, they work in Thunderbird. But whenever Cyclos had to send a mail the system hung and the browser finally timed the request out. The bug is VERY difficult to find, because there are no entries in the error log, it just hangs in Nirvana.

I finally found it on a hunch - it works when you go back to Port 25 and no TLS. I tried this on Ubuntu 10.04 / Tomcat 6 AND on Windows 7 / Tomcat 6.
Site Admin
Posts: 1424
Joined: Mon Jan 24, 2005 10:31 am

Post by admin »

This looks like a local problem.
There are various instances that use different SMTP settings/ports.
When a timeout it is logged.
Posts: 3
Joined: Fri Jun 13, 2014 9:24 am
Location: Kremenchuk, Ukraine

Re: [ Cyclos 3.6 ] Cyclos hangs with certain SMTP values

Post by tischenkoalex »

Just experienced the same situation with Cyclos 3.7.3: I configured GMail's smtp server with TLS and Cyclos was hanging when administrator tried to switch user's permission group "inactive" to "active".
The server hangs so that it can't be shut down properly (had to kill the process).

Thanks to timreeves for this post, I guess how much time it could take to find the reason.
Post Reply