write plain text when you send message

Functionality discussions and feature requests

Moderators: hugo, alexandre, rmvanarkel

Post Reply
alex.theoto
Posts: 4
Joined: Fri Jan 04, 2013 10:29 am

write plain text when you send message

Post by alex.theoto »

Hallo.
First of all, thank you for your excellent work on this project.
I'm new user on cyclos project and I know very few things about java, java script and generally program language...

My issue, as I mentioned on my title is:
When a user write a message (not sms) to another user or group, the text format has the ability to write with bold, italic e.t.c. but he cannot check his spelling via browser's feature -using right mouse click on the text area-. It doesn't open right click on the text body.
What I'm trying to do now is to change the rich text format into plain text format, so the user can right click on the body and see his spelling...

Now, I checked where the SendMessage body is and I found it @ cyclos_3.7.1/web/pages/members/messages/sendMessage.jsp.
As I suspect, the issue must be at the following lines:

<c:choose><c:when test="${cyclos:name(messageFormat) == 'PLAIN'}">
<html:textarea property="message(body)" styleId="bodyText" styleClass="full InputBox" rows="9" value="${body}" />
</c:when><c:otherwise>
<cyclos:richTextArea name="message(body)" styleId="bodyText" value="${body}" />
</c:otherwise></c:choose>

But I cannot understand how to specify from rich text format into plain text format. The first line has the PLAIN parameter but I don't understand the language...

Can someone help me to modify the code so the user can write his text in simple form and to use the browser's spellchecker?

Thank you very much...

admin
Site Admin
Posts: 1420
Joined: Mon Jan 24, 2005 10:31 am

Re: write plain text when you send message

Post by admin »

Hi,

Thanks for the kind comment.
The easiest way would to set the messages to use plain text in the admin section, menu: Settings - Local settings - Data display - Message format > change to Plain text

Hope this works for you

alex.theoto
Posts: 4
Joined: Fri Jan 04, 2013 10:29 am

Re: write plain text when you send message

Post by alex.theoto »

admin wrote:Hi,

Thanks for the kind comment.
The easiest way would to set the messages to use plain text in the admin section, menu: Settings - Local settings - Data display - Message format > change to Plain text

Hope this works for you

It worked... Thank you very much for your support...

Post Reply