Unable to Authorize REST Web service

Functionality discussions and feature requests

Moderators: hugo, alexandre, rmvanarkel

Post Reply
gavril
Posts: 1
Joined: Wed Jan 29, 2020 10:06 am

Unable to Authorize REST Web service

Post by gavril »

Version: 3.7.3

I am currently exploring the REST Web services listed here https://wiki3.cyclos.org/index.php/REST_Web_services

But I'm unable to successfully authorize any URI other than general which didn't need it

I always get the response invalid credentials, even though I can login successfully using the web.

Code: Select all

{
  "errorCode": "INVALID_CREDENTIALS",
  "errorDetails": "Invalid username / password"
}
Please help if there are anything that I need to setup first before I'm able to use REST.


If it's help, this is the response when I hit general

Code: Select all

{
  "cyclosVersion": "3.7.3",
  "applicationName": "Cyclos",
  "welcomeMessage": "Please change the following translation key (At the admin section: Translation - Application): mobile.welcomeMessage",
  "principalType": "USER",
  "credentialType": "LOGIN_PASSWORD",
  "images": [
    {
      "id": 41,
      "caption": "mobileSplash_large",
      "thumbnailUrl": "http://localhost/cyclos/thumbnail?id=41",
      "fullUrl": "http://localhost/cyclos/image?id=41",
      "lastModified": "2014-03-24T07:49:22.000+0000"
    },
    {
      "id": 32,
      "caption": "mobileSplash_medium",
      "thumbnailUrl": "http://localhost/cyclos/thumbnail?id=32",
      "fullUrl": "http://localhost/cyclos/image?id=32",
      "lastModified": "2014-03-24T07:49:21.000+0000"
    },
    {
      "id": 35,
      "caption": "mobileSplash_small",
      "thumbnailUrl": "http://localhost/cyclos/thumbnail?id=35",
      "fullUrl": "http://localhost/cyclos/image?id=35",
      "lastModified": "2014-03-24T07:49:22.000+0000"
    }
  ]
}

Post Reply