Problem adding custom fields

Any issue about installation and configuration of the Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
cyril_ACID
Posts: 2
Joined: Tue Jun 30, 2020 11:47 am

Problem adding custom fields

Post by cyril_ACID »

Hi everybody

I'm looking for adding new custom fields to my users. I've already created my fields in profile fields list, authorize de fields to be active, visible, and editable for the right products. I don't have "notFoundException" when I try to set it so the fields seems to be right configured, but the fields are not present in customValues after updating a user.

Can someone give me the process to follow to add a new field ? I'm stuck on this project because of this ..

rmvanarkel
Posts: 244
Joined: Tue Oct 05, 2010 1:14 pm

Re: Problem adding custom fields

Post by rmvanarkel »

Dear Cyril,

Your post is a bit cryptic, so you don't get an error if I understand it correctly:
I don't have "notFoundException"
And I am not completely sure what you mean with:
the fields are not present in customValues after updating a user
For now I can only guess, maybe the admin you are trying to view the profile with doesn't have the permission to see the fields? You can also send us your credentials so we can have a look.

cyril_ACID
Posts: 2
Joined: Tue Jun 30, 2020 11:47 am

Re: Problem adding custom fields

Post by cyril_ACID »

Hi Roder

What I mean by
I don't have "notFoundException"
is that my field is correctly found in Cyclos by my app. NotFoundExceptions are sent when trying to use an undefined customValue.

And when I said
the fields are not present in customValues after updating a user
I mean that I'm trying to update a user customFields in the same way that I always update it, but the concerned field are not being displayed when I fetch the user after the update.
I precise that I already have plenty of custom fields implemented that are working correctly.
My users are implemented as Products.( system -> user configuration -> products )

I will send you my credentials in few minutes
thank you for your time

rmvanarkel
Posts: 244
Joined: Tue Oct 05, 2010 1:14 pm

Re: Problem adding custom fields

Post by rmvanarkel »

As I said, you don't need to look at the product, but probably at the (group) permissions of the admin viewing the profile fields, he needs to have permission to view this profile fields of other users.

shashank
Posts: 7
Joined: Tue May 28, 2019 8:59 am

Re: Problem adding custom fields

Post by shashank »

cyril_ACID wrote:
Thu Jul 02, 2020 5:49 am
Hi everybody

I'm looking for adding new custom fields to my users. I've already created my fields in profile fields list, authorize de fields to be active, visible, and editable for the right products. I don't have "notFoundException" when I try to set it so the fields seems to be right configured, but the fields are not present in customValues after updating a user.

Can someone give me the process to follow to add a new field ? I'm stuck on this project because of this ..
Are you trying to access these fields through api or mobile app and only then you are not seeing them or are you not seeing them in web also? If they are seen in web it mostly will be a rights issue as admin said.

Regards,
Shashank

Post Reply