[4.11.3] Issue troubleshooting outbound SMS

Any issue about installation and configuration of the Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
simonjwoolf
Posts: 111
Joined: Mon May 28, 2012 8:49 am

[4.11.3] Issue troubleshooting outbound SMS

Post by simonjwoolf » Thu Feb 28, 2019 12:05 pm

I'm trying to troubleshoot outbound SMS, using a configuration and a gateway that work perfectly on another server.
Yet, on the new machine, all outbound SMS fail with "UNKNOWN ERROR" in Cyclos.

The error is the same whether a notification is triggered (eg: by making a payment) or when using the "mailing list" function.
In this latter case, a success message is written to Catalina.out:

Code: Select all

2019-02-28T15:53:16.764+01:00	SUCCESS	Main web	213.127.4.250	B£ Admin	MailingListService	send	{"body":"test message contact","type":"SMS","toUsers":[2068777009400000000]}	1	27ms
2019-02-28T15:53:16.911+01:00	Mailing processing	1	146ms
However the outbound message is not sent to the gateway, and appears in the outbound messages report with a status code of "Unknown error"

I have enabled SMS logging in the log4j.properties file, but this hasn't helped. There is no sign of any error logging, so its impossible to see what's going wrong here.

Anyone have any ideas?
---
Simon Woolf
Cyclos Consultant

simonjwoolf
Posts: 111
Joined: Mon May 28, 2012 8:49 am

Re: [4.11.3] Issue troubleshooting outbound SMS

Post by simonjwoolf » Thu Feb 28, 2019 12:15 pm

Just spotted that my working server is running Cyclos 4.10.3

Has something changed between 4.10.3 and 4.11.3 that might be affecting this?
---
Simon Woolf
Cyclos Consultant

Willox
Posts: 5
Joined: Mon May 06, 2019 4:19 pm

Re: [4.11.3] Issue troubleshooting outbound SMS

Post by Willox » Tue May 07, 2019 8:09 am

Hello Simon,

Did you fix your Outbound SMS issue with the MailingListService?

Regards

William

Post Reply