Return incorrect URL after running API

Any issue about installation and configuration of the Cyclos 4 version

Moderators: hugo, alexandre, rmvanarkel

Post Reply
trustpay
Posts: 61
Joined: Mon Aug 03, 2015 10:19 am

Return incorrect URL after running API

Post by trustpay » Fri Nov 10, 2017 7:20 am

Dear Cyclos team

We have build your Cyclos in 2 version:
- Test version is: https://center.trustpay.vn
- Production version is: https://trustbank.asia

But, when running API at https://trustbank.asia/api, the Request URL always return to: https://center.trustpay.vn/api/xxxxxxxx (please see in attached picture)
Please guide us how to fix this problem? This is really important to us

Many thanks
Attachments
NEED SUPPORT FOR CONFIGURATION.png
NEED SUPPORT FOR CONFIGURATION.png (64.63 KiB) Viewed 737 times

rmvanarkel
Posts: 240
Joined: Tue Oct 05, 2010 1:14 pm

Re: Return incorrect URL after running API

Post by rmvanarkel » Fri Nov 10, 2017 8:22 am

Dear Trustpay,

Probably you copied the database from the test instance to the production version when you were ready setting up the system. Is this indeed the case? Hopefully the fix for this is very easy, can you first have a look at your default configuration, so you go system > configurations > Open the default configuration (the one on top of the list). And make the Main URL has the right address set. The REST/Swagger documentation/interface only uses this url when a proxy is used in front of the server (see cyclos.properties cyclos.header.remoteAddress = X-Forwarded-For). I hope this will solve the problem, if not please let us know!

Best regards,

trustpay
Posts: 61
Joined: Mon Aug 03, 2015 10:19 am

Re: Return incorrect URL after running API

Post by trustpay » Thu Mar 01, 2018 4:49 am

rmvanarkel wrote:Dear Trustpay,

Probably you copied the database from the test instance to the production version when you were ready setting up the system. Is this indeed the case? Hopefully the fix for this is very easy, can you first have a look at your default configuration, so you go system > configurations > Open the default configuration (the one on top of the list). And make the Main URL has the right address set. The REST/Swagger documentation/interface only uses this url when a proxy is used in front of the server (see cyclos.properties cyclos.header.remoteAddress = X-Forwarded-For). I hope this will solve the problem, if not please let us know!

Best regards,
Thanks rmvanarkel!
And we have another problem when run domain/api from another network.
For examble:
We have network default https://center.trustpay.vn its run very well.
We have another network https://center.trustpay.vn/giftcard, we want run https://center.trustpay.vn/giftcard/api and meet this problem.

Please help us!
Thanks!
Attachments
Capture.PNG
Capture.PNG (22.78 KiB) Viewed 669 times

Post Reply