Running in Eclipse

Any issue about installation and configuration of the Cyclos software

Moderators: hugo, alexandre, rmvanarkel

Post Reply
max_factori
Posts: 2
Joined: Tue Nov 11, 2008 8:14 am

Running in Eclipse

Post by max_factori » Tue Nov 11, 2008 9:41 am

Hi - Thanks for making Cyclos open source. I am impressed by the rich functionality and also found the code to be very well written.

I have 2 questions about the project :

1) Is it necessary to copy the JARS from cyclos3_web/lib to Tomcat/lib for Cyclos to start ? this was what i had to do. Ideally, I'd like to keep the JARS in WEB-INF/lib. Is this possible in Eclipse/Tomcat ? My usual IDE is JDeveloper and so, am new to Eclipse.

2) in the cyclos3_build project, is the build.xml file be used for building the Cyclos WAR file ? I tried running it and got the error below. As a workaround, I managed to use the Export function to create a cyclos3 warfile.

----------------------------------------
Buildfile: C:\cyclos_cvs\cyclos3_build\build.xml
compile:
[javac] Compiling 1397 source files to C:\cyclos_cvs\cyclos3_build\build\bin
[javac] C:\cyclos_cvs\cyclos3\src\nl\strohalm\cyclos\utils\DataObject.java:36: type parameters of <D>D cannot be determined; no unique maximal instance exists for type variable D with upper bounds D,nl.strohalm.cyclos.utils.DataObject
[javac] return cloneObject();
[javac] ^
[javac] Note: Some input files use unchecked or unsafe operations.
[javac] Note: Recompile with -Xlint:unchecked for details.
[javac] 1 error

----------------------------------------

Any help will be much appreciated.

Best regards,
Max

Post Reply