[Cyclos 3.7.3] - Vanilla Install runs but can't log in

Any issue about installation and configuration of the Cyclos software

Moderators: hugo, alexandre, rmvanarkel

Post Reply
timreeves
Posts: 54
Joined: Fri Feb 12, 2010 8:30 am

[Cyclos 3.7.3] - Vanilla Install runs but can't log in

Post by timreeves » Sat Jan 04, 2014 7:21 pm

Hi all,

I just installed Cyclos on a new server. New everything. Tomcat runs fine, vanilla Cyclos runs, has populated its DB fine, even accepts a new registration - but I can't log in as super user.

It accepts the credentials (admin, 1234) and replies with success...

validation=true&operatorLogin=false&principalType=USER&principal=admin&password=1234
<?xml version='1.0' encoding='UTF-8'?><status value='success'></status>

I see the screen "Application is being loaded. Please wait..." for a brief second - BUT then it falls back to the login screen. The only mods I made to the vanilla 3.7.3 before packaging a war were these in WEB-INF/classes/cyclos.properties
cyclos.embedded.locale = de_DE
...
hibernate.connection.url = jdbc:mysql://localhost/cyclos_test
hibernate.connection.username = cyclos_test
hibernate.connection.password = shunyata69
...
kaptcha.obscurificator.impl=com.google.code.kaptcha.impl.WaterRipple

Here's my situation:
- Ubuntu 12.04 LTS
- Installed package openjdk-7-jre (with all dependencies) (JVM Version 1.7.0_25-b30)
- Manually installed apache-tomcat-7.0.47 (to /var/local/tomcat7)
- JAVA_HOME=/usr/lib/jvm/java-7-openjdk-amd64
- JAVA_OPTS="-Djava.awt.headless=true -Xms128M -Xmx512M -XX:MaxPermSize=256m"
- CATALINA_OPTS="-Dfile.encoding=UTF-8"

Take a look: http://87.230.18.99:8080/test/do/login

Where can I look to find out what's happening / what can I try to get it working?

Thanks!

Tim

admin
Site Admin
Posts: 1413
Joined: Mon Jan 24, 2005 10:31 am

Re: [Cyclos 3.7.3] - Vanilla Install runs but can't log in

Post by admin » Mon Jan 06, 2014 9:01 am

Hi,

This is probably due to a time zone setting.
Here is some information about that: http://www.cyclos.org/wiki/index.php/In ... _time_zone

Post Reply