Cyclos Standalone - MySQL - Cloud

Any issue about installation and configuration of the Cyclos software

Moderators: hugo, alexandre, rmvanarkel

Post Reply
Posts: 1
Joined: Mon May 27, 2013 9:23 am

Cyclos Standalone - MySQL - Cloud

Post by Drew »

Hi folks,

I'm installing the Cyclos standalone app as a cloudfoundry/aPaaS application, using a relational database (MySql) provisioned by my service provider. I used the standalone application because it includes the full tomcat and I don't have to use the one provided by the cloudfoundry implementation

In any event, I got Cyclos running first with the embedded DB - that worked fine.
Now, I'm trying to get it running with the MySQL instance. I get the app running, but when i attempt to login the first time, I am immediately returned to the login screen (not bad username/password).

I suspect that I have a timezone missmatch between the application and the database server. The database server is in US/Pacific time (-7:00). The server is also running in US Pacific time. I have looked at the login history table and see a login granted, and then an immediate logout...

I've tried every time zone from +1:00 to -12:00 and each one fails with the same result.

Interestingly, the MySQL timezone "name" support is not available on this provisioned instance, so I'm simply using -7:00 rather than the nice names in the config.

Is there any way to determine what the mismatch is?

Again, I'm using the latest Cyclos "standalone" package as I'm simply executing the jar file with all the embedded tomcat, etc.

Post Reply