Search found 113 matches

by simonjwoolf
Tue Jun 21, 2016 9:57 am
Forum: Installation & Configuration issues
Topic: Issue upgrading a site from 4.5.3 to 4.6 Beta
Replies: 4
Views: 3221

Re: Issue upgrading a site from 4.5.3 to 4.6 Beta

Thanks, Mea Culpa that I didn't read the notes properly. Still awaiting confirmation about whether earlier versions of Cyclos can run with Java 8, or whether we would have to have a mixed Java environment (v 7 & 8 on same server, with different Tomcat instances) if we are running a production si...
by simonjwoolf
Tue Jun 21, 2016 9:20 am
Forum: Installation & Configuration issues
Topic: Issue upgrading a site from 4.5.3 to 4.6 Beta
Replies: 4
Views: 3221

Re: Issue upgrading a site from 4.5.3 to 4.6 Beta

OK, so from a quick google it seems this refers to a JRE version mismatch. From 4.6 do we need to upgrade to JRE 1.8? # java -version java version "1.7.0_101" OpenJDK Runtime Environment (IcedTea 2.6.6) (7u101-2.6.6-0ubuntu0.12.04.1) OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)
by simonjwoolf
Tue Jun 21, 2016 9:11 am
Forum: Installation & Configuration issues
Topic: Issue upgrading a site from 4.5.3 to 4.6 Beta
Replies: 4
Views: 3221

Issue upgrading a site from 4.5.3 to 4.6 Beta

When upgrading from a working 4.5.3 install to 4.6 Beta, and then restarting Tomcat, the site no longer starts. The upgrade was done by replacing the entire /web directory and copying in the pre-existing cyclos.properties file from the old version The key issue appears to be: org/cyclos/bootstrap/Se...
by simonjwoolf
Tue Mar 29, 2016 11:09 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.5.3] Account balances not in sync after tx import
Replies: 6
Views: 2527

Re: [Cyclos 4.5.3] Account balances not in sync after tx imp

Thanks, this works well. You just made one small error in the second sql statement. It should be:

Code: Select all

update accounts set negative_since = null where balance_diff(id) >= 0
by simonjwoolf
Tue Mar 29, 2016 9:46 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.5.3] Account balances not in sync after tx import
Replies: 6
Views: 2527

[Cyclos 4.5.3] Account balances not in sync after tx import

We are migrating data from a Cyclos 3.7.3 installation. Following discussions with you, we discovered that we cannot currently use the import tool in Cyclos 4.5 to import either chargebacks or scheduled payments. We have therefore decided to do direct imports to the Postgresql database for all the t...
by simonjwoolf
Wed Mar 16, 2016 11:47 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.5.3] How can chargebacks from 3.7.3 be imported?
Replies: 2
Views: 2076

Re: [Cyclos 4.5.3] How can chargebacks from 3.7.3 be importe

That is a bit dissappointing.

Is this expected to be fixed in a later release?
by simonjwoolf
Wed Mar 16, 2016 10:11 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.5.3] How can chargebacks from 3.7.3 be imported?
Replies: 2
Views: 2076

[Cyclos 4.5.3] How can chargebacks from 3.7.3 be imported?

We are using the import transfer tools in Cyclos4 Pro to import a complete transaction history from an older Cyclos 3.7.3 system. Chargebacks are being rejected as invalid, because the amount field is negative. How should we thus import chargebacks? Do we need to reverse sender and recipient, or is ...
by simonjwoolf
Mon Aug 10, 2015 11:36 am
Forum: Bug - problem reporting
Topic: Problem with Cyclos4 site moved to new url
Replies: 3
Views: 3833

Re: Problem with Cyclos4 site moved to new url

Brilliant - that did the job. It was indeed an out of date database. I had thought it should upgrade itself automatically?
by simonjwoolf
Mon Aug 10, 2015 11:04 am
Forum: Bug - problem reporting
Topic: Problem with Cyclos4 site moved to new url
Replies: 3
Views: 3833

Problem with Cyclos4 site moved to new url

We have migrated a cyclos4 site to a slightly changed url and a new Tomcat instance (eg: the webapp was called "c44" now it's called "cyclos"). This was done simply by moving all the files in Cataline home to a new location, and then linking to the same database as before. This a...
by simonjwoolf
Tue May 19, 2015 10:05 am
Forum: Cyclos Bug - problem reporting
Topic: how to use cyclos REST API
Replies: 1
Views: 18606

Re: how to use cyclos REST API

Hi,

The REST web sevices are well documented here: http://www.cyclos.org/wiki/index.php/REST_Web_services

Simon
by simonjwoolf
Thu Apr 02, 2015 12:00 pm
Forum: Bug - problem reporting
Topic: [Cyclos 4.3.1] No log of sent/ received SMS in Cyclos 4
Replies: 2
Views: 1676

Re: [Cyclos 4.3.1] No log of sent/ received SMS in Cyclos 4

Many thanks, this is useful. Don't know why I wasn't capable of spotting that table!
by simonjwoolf
Tue Mar 31, 2015 10:44 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.3.1] No log of sent/ received SMS in Cyclos 4
Replies: 2
Views: 1676

[Cyclos 4.3.1] No log of sent/ received SMS in Cyclos 4

In cyclos 3.7 it was possible to view a log showing the number of sent SMS messages. It was further possible to query the tables driver_log and sms_logs to get a total of number of SMS sent and received in a given period. Cyclos 4 doesn't seem to have any equivalent. This is making it very difficult...
by simonjwoolf
Mon Mar 02, 2015 10:16 am
Forum: Bug - problem reporting
Topic: [Cyclos 4.3.1] Bug restricting SMS pay to specific groups
Replies: 1
Views: 1559

[Cyclos 4.3.1] Bug restricting SMS pay to specific groups

We have discovered what looks like a bug in cyclos 4.3.1 in 4.2.1 we had a working SMS payment transaction type, which is restricted to two groups. Both groups belong to the same groupset. After upgrading to 4.3.1, this ceased to function, and any attempts to make an SMS payment invoking this transa...
by simonjwoolf
Tue Oct 07, 2014 9:59 am
Forum: Installation & Configuration issues
Topic: [Cyclos 4.2.1] SMS acinfo cmd doesn't work unless pin is set
Replies: 1
Views: 2016

[Cyclos 4.2.1] SMS acinfo cmd doesn't work unless pin is set

We have found a quirk in the incoming SMS implementation: We have SMS configured not to require any kind of password or pin, when requesting account info or making a payment. We follow this test workflow: 1. Create a new user, with a mobile phone no enabled for SMS 2. This user then sends the "...
by simonjwoolf
Tue Oct 07, 2014 9:55 am
Forum: Installation & Configuration issues
Topic: [Cyclos 4.2.1] Can't separate incoming SMS on different port
Replies: 6
Views: 50005

Re: [Cyclos 4.2.1] Can't separate incoming SMS on different

In the end, I've solved this by having a proxy handler in the http stanza, which just sends the specific SMS url to tomcat (via AJP). Since no other urls are matched in the http stanza, any attempt to access other urls via http results in 404 - not ideal, but for some reason I can't get the rediect ...