Search found 80 matches

by martin.rueegg
Thu Dec 14, 2017 8:16 am
Forum: Scripting & Webservices issues
Topic: Reloading autocomplete information in eclipse
Replies: 1
Views: 481

Re: Reloading autocomplete information in eclipse

Response from Luis: Hi Martin. (...) Regarding Eclipse, it should take into account the build path changes immediately. You should have "Project > Build automatically" checked. Also, if you run a Groovy file as script, then it does copies the entire class path to the run configuration. If you change...
by martin.rueegg
Thu Dec 14, 2017 8:15 am
Forum: Scripting & Webservices issues
Topic: Setting Payments authorization on MemberProduct
Replies: 1
Views: 501

Re: Setting Payments authorization on MemberProduct

Response from Luis: Hi Martin. There are lots of processing that takes place when we save a product. The correct way to grant the permission to authorize payments to a member product would be: import org.cyclos.entities.users.MemberProduct import org.cyclos.model.users.products.AuthorizedPaymentsOpe...
by martin.rueegg
Thu Dec 14, 2017 6:30 am
Forum: Scripting & Webservices issues
Topic: Reloading autocomplete information in eclipse
Replies: 1
Views: 481

Reloading autocomplete information in eclipse

Hello everyone, I'm using eclipse to do most of the scripting development. I used to have the libraries of v4.8.5 in the BuildPath and autocomplete worked flawlessly. However, I've now updated the linked libraries to point to the v4.9 version of the files and autocomplete still shows the old informa...
by martin.rueegg
Thu Dec 14, 2017 6:27 am
Forum: Scripting & Webservices issues
Topic: Setting Payments authorization on MemberProduct
Replies: 1
Views: 501

Setting Payments authorization on MemberProduct

Hello I'm currently writing a library to dump and re-load the Cyclos configuration. However, I can't find a way to set the Payment authorization on a MemberProduct. I was trying to find how to set the Payments authorization for a MemberProduct using the script. The documentation gave me no clue wher...
by martin.rueegg
Thu Dec 07, 2017 10:14 am
Forum: Bug - problem reporting
Topic: EntityManagerHandler fails on search for INamedEntity
Replies: 4
Views: 912

Re: EntityManagerHandler fails on search for INamedEntity

Hi Luis, Thanks for your response. Actually, EntityManagerHandler can find entities by internal name, not by name. Then this is not in line with the documentation : find (java.lang.Class<E> entityClass , java.lang.String internalName ) Finds the given entity by internal name in the current network. ...
by martin.rueegg
Wed Dec 06, 2017 7:51 pm
Forum: Bug - problem reporting
Topic: EntityManagerHandler fails on search for INamedEntity
Replies: 4
Views: 912

Re: EntityManagerHandler fails on search for INamedEntity

Unfortunately, CustomScriptQuery also doesn't support name as a query parameter. Otherwise something like the following might be possible (obviously, also a hack with load and toEntity ...): import org.cyclos.entities.system.CustomScript; import org.cyclos.model.system.scripts.*; def o = binding.cus...
by martin.rueegg
Wed Dec 06, 2017 7:41 pm
Forum: Bug - problem reporting
Topic: EntityManagerHandler fails on search for INamedEntity
Replies: 4
Views: 912

Re: EntityManagerHandler fails on search for INamedEntity

As a work-around, the following code can be used: import org.cyclos.entities.system.CustomScript; import org.cyclos.model.system.scripts.ScriptType; CustomScript cs = binding.customScriptService.listByType(ScriptType.EXTENSION_POINT).find{it.name == 'epLoanGenerateNumber'}; Which is obviously not as...
by martin.rueegg
Wed Dec 06, 2017 7:09 pm
Forum: Bug - problem reporting
Topic: EntityManagerHandler fails on search for INamedEntity
Replies: 4
Views: 912

EntityManagerHandler fails on search for INamedEntity

Hello I'm trying to get an object of a CustomScript : import org.cyclos.entities.system.CustomScript; CustomScript o = entityManagerHandler.find(CustomScript, 'scriptName'); According to the documentation, EntityManagerHandler should search using the 'name' property, if entityClass implements INamed...
by martin.rueegg
Mon Oct 02, 2017 10:53 am
Forum: Scripting & Webservices issues
Topic: Problem with REST API Authentication
Replies: 5
Views: 1403

Re: Problem with REST API Authentication

Apologies, the following is obviously nonsense:
martin.rueegg wrote: Just one note re your question: AdService has no search method ...
The method exists!

Please create a new forum entry and we'll discuss it further there.

Martin.
by martin.rueegg
Mon Oct 02, 2017 10:49 am
Forum: Scripting & Webservices issues
Topic: Problem with REST API Authentication
Replies: 5
Views: 1403

Re: Problem with REST API Authentication

Hi David, i am getting error same like that.. No, actually, it is not the same error and a completely unrelated question. The original question is about authentication, not about an UNKNOWN error when using the API. Furthermore it would be helpful if you could put your code in [code] [/code] tags, s...
by martin.rueegg
Mon Oct 02, 2017 10:33 am
Forum: Scripting & Webservices issues
Topic: Problem with REST API Authentication
Replies: 5
Views: 1403

Re: Problem with REST API Authentication

Hi All, Cyclos\Configuration::setRootUrl("https://bank.ppayinc.com"); Cyclos\Configuration::setAuthentication("Dpwebb", "Cookies99"); Hi David, Never add your actual credentials on a public post. Not even in a forum that requires access. I've logged in and changed the password and informed you by e...
by martin.rueegg
Thu Sep 07, 2017 7:21 am
Forum: Scripting & Webservices issues
Topic: Accessing getAccountHistoryStatus from PHP
Replies: 5
Views: 1231

Re: Accessing getAccountHistoryStatus from PHP

Hi Bhasker Sorry for my late response. You were on the right path, but instead of just account type, you need to pass the actual account to the account paramater. Best you use the id. Furthermore, in order to get balanceAtEnd and balanceAtBegin , you need to define a period: $accountService = new Cy...
by martin.rueegg
Thu Sep 07, 2017 6:57 am
Forum: Scripting & Webservices issues
Topic: Access password with two different configurations
Replies: 1
Views: 558

Access password with two different configurations

Hello I have the following configurations; - network default ( default ) \- PIN access ( pin ) I also have a user defined channel "myChannel". This channel is enabled on both configurations, however on default , it is set to use the login password as access password, while on pin it is set to use th...
by martin.rueegg
Thu Sep 07, 2017 6:47 am
Forum: Scripting & Webservices issues
Topic: Problem with REST API Authentication
Replies: 5
Views: 1403

Re: Problem with REST API Authentication

HI logzy would be great if you could provide the code you're using as it is hard to tell what might go wrong. Below you can see how I did it. PLEASE NOTE: it's just a proof of concept and there is no error handling implemented yet which is especially crucial for the blocking and unblocking of the to...