Search found 12 matches

by afzal
Sun Mar 31, 2013 12:07 am
Forum: Installation issues
Topic: How to install cyclos with oracle 11g as Database
Replies: 0
Views: 2149

How to install cyclos with oracle 11g as Database

Hi! Good morning. I would like to install cyclos with oracle 11G as database. I really do not have any choice other than using oracle because of clients demand. Please let me know if there are any documentation on cyclos installation with oracle. We need to solve this as soon as possible. Any help w...
by afzal
Thu Dec 13, 2012 5:10 am
Forum: Installation issues
Topic: How to configure restful webservice in cyclos 3.7.1
Replies: 1
Views: 2825

Re: How to configure restful webservice in cyclos 3.7.1

Hi! I have manged to fix this. Now the restful web service also working fine. I have done the following to make it work: Created Web service client by choosing mobile phone application as channel & setup http username and password Setting Mobile Application Channel in Permission Groups-> Full Member...
by afzal
Wed Dec 12, 2012 3:49 am
Forum: Installation issues
Topic: How to configure restful webservice in cyclos 3.7.1
Replies: 1
Views: 2825

How to configure restful webservice in cyclos 3.7.1

Hi! I have recently started working on cyclos. Have spent some time and the application is up and running. I can use SOAP webservice. Now I would like to use RESTFul web service. I was trying to see the list of rest services through http://localhost:8080/cyclos/rest but did not work. It give the fol...
by afzal
Tue Dec 11, 2012 9:13 am
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Hi!

I have solved the problem.

The main problem was setting Web Service client. I was setting http user and http password which is not necessary in this case.

Anyway thanks Alexandre for helping me out for this issue.

Thanks
by afzal
Tue Dec 11, 2012 8:12 am
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Hi! Could someone let me know what should be the web service url value in new channel creation screen? I am using http://localhost:8080/cyclos/services/payment Is it correct based on the root URL http://localhost:8080/cyclos/ in my local machine or I need to change this. Or if someone write down the...
by afzal
Mon Dec 10, 2012 9:34 pm
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre, The system is resolving IP correctly, I have observed while debugging AuthInterceptor.resolveeClient , it has passed 192.168.1.114 as remote address. But ServiceClientService.findByAddressAndCredentials does not recognize username and password, therefore it returns null and as a resu...
by afzal
Mon Dec 10, 2012 3:08 pm
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre, Thanks for your reply again. I am using Windows 7 64bit. The following software are used for the development environment: 1. Eclipse: Eclipse Java EE IDE for Web Developers. Version: Indigo Service Release 2 Build id: 20120216-1857 2. JDK: jdk1.6.0_37 3. Tomcat: apache-tomcat-6.0.36 ...
by afzal
Mon Dec 10, 2012 2:34 pm
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre,

Thanks for your reply again.

Yes I am trying with a member restricted webservice.

Yes I have enabled Member menu -> personal-> external access.

Thanks.
by afzal
Mon Dec 10, 2012 2:10 pm
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre, Thanks for your reply again. I have tried with local host first. Then also tried with the hostname of the laptop and at last tried with IP address but nothing worked out. It seems like I am missing something while configuring this web service. If you could give me the details step fo...
by afzal
Mon Dec 10, 2012 10:09 am
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre,

The attachment may give better picture on this.

Thanks.
by afzal
Mon Dec 10, 2012 9:31 am
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

Re: How to use webservice in cyclos 3.7.1

Dear Alexandre, Thanks for your reply. I have followed all the steps but could not manage to get it work for me. I have configured a new channel, created a webservice client to use this new channel, grant permissions to a member group to use this channel and the channel is enabled on members externa...
by afzal
Mon Dec 10, 2012 8:10 am
Forum: Installation issues
Topic: How to use webservice in cyclos 3.7.1
Replies: 14
Views: 9441

How to use webservice in cyclos 3.7.1

Hi! I am new to cyclos system. I have spent some time getting familiar with Cyclos system on local server. I have now installed a cyclos onto my laptop and it is running without any problem. But when I am trying to connect to cyclos web service I am getting Server error: unauthorized-access. Thanks ...